El sonido Bug de Moon Patrol

Para cualquier plataforma ATARI, computadores o consolas.
Responder
Carmelo08
novice
novice
Mensajes: 5
Registrado: Dom May 02, 2021 8:15 pm
Reputación: 2

El sonido Bug de Moon Patrol

Mensaje por Carmelo08 »

Hola a todos, tengo una pregunta, se que algunos se me van a venir encima, pero el Moon Patrol como sabemos la version NTSC tenía un Bug con el sonido el cual lo hace diferente a la version PAL. He visto que muchos lo han corregido con un ATR, y que incluso el ALTIRRA 3.9 que es el programa que uso, lo corrige automáticamente dando el sonido verdadero, ahora viene lo bueno.....

ALGUIEN SABE COMO DESACTIVAR ESA CORRECCION AUTOMATICA EN ALTIRRA 3.9???????????

Por cuestiones de Nostalgia, quiero jugar con el sonido antiguo, es mas, ese sonido antiguo lo siento mas LUNAR que el corregido, me gusta mas el sonido con el que conocí MOON PATROL, y con el que si prendo ahorita mi 130XE escucharía, alguien podría ayudarme?

Avatar de Usuario
vitoco
expert
expert
Mensajes: 861
Registrado: Mié Nov 08, 2006 7:25 pm
Reputación: 4
Contactar:

Re: El sonido Bug de Moon Patrol

Mensaje por vitoco »

Hola.

¿Puedes poner un enlace a la versión "con bug" a la que te refieres?

Quiero saber si estás hablando algo distinto a la versión para 5200 que fue portada para 800 (antiguo), pero que en XL/XE suena como bzzzz....

Altirra puede usar varias ROM en el SO, pero si no le pasas las ROM, usa su AltirraOS y tal vez eso cambie el comportamiento, "arreglando" el sonido.

Carmelo08
novice
novice
Mensajes: 5
Registrado: Dom May 02, 2021 8:15 pm
Reputación: 2

Re: El sonido Bug de Moon Patrol

Mensaje por Carmelo08 »

Hola, aquí tienes 2 videos para que compares.

ESTE ES EL CORRECTO, O SEA, LO QUE EL ALTIRRA CORRIGE, LOS QUE LOS USUARIOS EN PAL Y LOS DE 5200 SIEMPRE HAN TENIDO


ESTE ES AL QUE ME REFIERO, LOS QUE VIVIMOS EN LA REGION NTSC Y USAMOS EL 800XL o 130XE en DISKETTE o CASSETTE, LO CONOCIMOS CON ESTE SONIDO.


Esa diferencia de sonidos entre ambos se le consideraba un BUG para la región NTSC.

vitoco escribió:
Lun May 03, 2021 10:23 am
Hola.

¿Puedes poner un enlace a la versión "con bug" a la que te refieres?

Quiero saber si estás hablando algo distinto a la versión para 5200 que fue portada para 800 (antiguo), pero que en XL/XE suena como bzzzz....

Altirra puede usar varias ROM en el SO, pero si no le pasas las ROM, usa su AltirraOS y tal vez eso cambie el comportamiento, "arreglando" el sonido.

Avatar de Usuario
vitoco
expert
expert
Mensajes: 861
Registrado: Mié Nov 08, 2006 7:25 pm
Reputación: 4
Contactar:

Re: El sonido Bug de Moon Patrol

Mensaje por vitoco »

Al menos me quité la duda y sí se trata de la versión para 5200 modificada para A8.

Cargué el XEX que tengo en mi colección desde 1984 y tiene los sonidos sucios en Altirra 4.0-test34, es decir no los arregla para NTSC. Si lo cambio a PAL, el sonido tampoco se arregla, sólo anda más lento, así que no se trata de PAL versus NTSC.

Por lo que puedo ver en tu segundo video (XL/XE OS), ahí pudiste usar el emulador para obtener los sonidos "originales" de esa versión. ¿No fue en Altirra?

Al menos yo no conozco si existe alguna opción de autocorrección en Altirra, y si es que existe, no la tengo habilitada.

Carmelo08
novice
novice
Mensajes: 5
Registrado: Dom May 02, 2021 8:15 pm
Reputación: 2

Re: El sonido Bug de Moon Patrol

Mensaje por Carmelo08 »

El video no es mío, lo encontré en Youtube, sin embargo después de mucho luchar al fin di con el problema, y que quede como precedente para cualquiera que desee jugarlo del modo que a mi me gusta.

Hay que agregar los archivos ROM que usábamos en el ATARI 800WIN, no las que trae el Altirra por defecto. Primero en Configure System, en la parte de System poner en 1200XL, luego en Firmware apretar en Firmware Manager, allí agregar los 5 ROM, y aceptar, luego en Operating System poner el Atari XL/XE, y en Basic el Atari Basic rev. C

Finalmente funcionó

Avatar de Usuario
ZZT
Site Admin
Site Admin
Mensajes: 10819
Registrado: Mar Nov 07, 2006 2:45 pm
Reputación: 5
Ubicación: La Florida-Santiago-Chile
Contactar:

Re: El sonido Bug de Moon Patrol

Mensaje por ZZT »

La versión "original" de moon patrol venía con el sonido espantoso, pero se arreglaba cargando primero el programa fixx xl, eso reparaba el sonido. Lamentablemente no lo hace a la inversa. Que yo recuerde. :-D

Avatar de Usuario
Marcelo-Z
expert
expert
Mensajes: 673
Registrado: Sab Nov 11, 2006 12:48 am
Reputación: 2

Re: El sonido Bug de Moon Patrol

Mensaje por Marcelo-Z »

Vaya me alegro de a alguien les haya servido el par de vídeos que hice hace rato ya.

Saludos

Avatar de Usuario
vitoco
expert
expert
Mensajes: 861
Registrado: Mié Nov 08, 2006 7:25 pm
Reputación: 4
Contactar:

Re: El sonido Bug de Moon Patrol

Mensaje por vitoco »

¡Gracias Marcelo-Z!

Lo simpático es que el juego portado a A8 fue modificado recientemente por Tix y Playsoft para mejorar la gráfica y las animaciones (versión "redux"), y luego portado de vuelta a su plataforma 5200 de origen por el mismo Playsoft, obviamente conservando el audio correcto.

... y no tiene nada que ver con la versión tenliner Patrol que hice en A8 el año pasado, y que también estará disponible para 5200 en breve.

Responder